The Official Star Trek Movie Forum

The Official Star Trek Movie Forum > Star Trek > Star Trek XI: The Movie > The much-dreaded ST09 DVD "it must be something wrong with your player" thread. :p
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #11  
Old 11-25-2009, 06:45 PM
Beetlescott's Avatar
Beetlescott Beetlescott is offline
Captain
 
Join Date: Feb 2008
Location: Louisville, KY
Posts: 1,645
Default

I bought a Samsung BluRay player last Summer, and I love it! The player is hooked to my internet for the updates. My problem is when I play my series discs, sometimes it won't play. It will act like a disc that "freezes" up or skips. The good news is when it happens, I stop the player, turn it completely off, and back on again. So far, it works. Another nice feature, when you play a regular DVD on the BluRay player, if you have those "freeze ups", It usually corrects itself and keeps on playing! I haven't yet had a disc that won't play at all. the only problem I have is with the Trek series. Prolly because I watch it most of the time. GREAT THREAD!
__________________
LET'S MAKE SURE HISTORY NEVER FORGETS THE NAME ENTERPRISE!!!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 04:58 PM.


Forum theme courtesy of Mark Lambert
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © 2009 by Paramount Pictures. STAR TREK and all related
marks and logos are trademarks of CBS Studios Inc. All Rights Reserved.